Windows 7 Unable to Connect
Incident Report for LTI Optics LLC
Resolved
A change in our hosting provider eliminated support for TLS 1.0, which is the default in Windows 7. Most hosting platforms have disabled TLS 1.0 due to significant security vulnerabilities.

The solution is for users to apply the update and registry modifications to set the default TLS version in Windows 7 to TLS 1.2

https://www.ltioptics.com/en/support-my-photopia.html#win7
Posted Aug 10, 2021 - 07:24 MDT
Identified
Some users on Windows 7 SP1 are unable to obtain a license from our license servers. We are testing a fix and will notify all impacted customers when this is resolved.
Posted Aug 09, 2021 - 16:33 MDT
This incident affected: my | photopia backend hosting.